app-text/asciidoc: 9.0.0_rc1 version bump
[gentoo.git] / app-text / tokyodystopia / tokyodystopia-0.9.15.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
7 HOMEPAGE="https://fallabs.com/tokyodystopia/"
8 SRC_URI="https://fallabs.com/tokyodystopia/${P}.tar.gz"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="examples"
14
15 DEPEND="dev-db/tokyocabinet"
16 RDEPEND="${DEPEND}"
17
18 PATCHES=(
19         "${FILESDIR}/fix_rpath.patch"
20         "${FILESDIR}/fix_ldconfig.patch"
21         "${FILESDIR}/remove_docinst.patch"
22 )
23
24 src_configure() {
25         econf --libexecdir="${EPREFIX}"/usr/libexec/${PN}
26 }
27
28 src_install() {
29         HTML_DOCS=( doc/. )
30
31         default
32
33         if use examples; then
34                 insinto /usr/share/${PF}/example
35                 doins example/.
36         fi
37 }
38
39 src_test() {
40         emake -j1 check
41 }