dev-libs/cdk: ppc stable wrt bug #575040
[gentoo.git] / app-text / tidy-html5 / tidy-html5-5.1.9.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils
8
9 DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
10 HOMEPAGE="http://www.html-tidy.org/"
11 SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.zip -> ${P}.zip"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="!app-text/htmltidy"
20
21 S="${WORKDIR}/${P}"
22
23 DOCS=( {CODESTYLE,README,CONTRIBUTING,LICENSE,VERSION}.md )
24 HTML_DOCS=( README.html )
25
26 BUILD_DIR="${S}/build/cmake"
27
28 src_configure() {
29         local mycmakeargs=(
30                 -DCMAKE_INSTALL_PREFIX=/usr
31                 -DCMAKE_BUILD_TYPE=Release
32         )
33
34         cmake-utils_src_configure
35 }
36
37 src_compile() {
38         cd build/cmake || die
39         cmake-utils_src_compile
40 }
41
42 src_install() {
43         cmake-utils_src_install
44 }