app-text/txt2tags: amd64 stable wrt bug #565662
[gentoo.git] / app-text / refbase / refbase-0.9.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6 inherit depend.apache webapp
7
8 DESCRIPTION="Web-based solution for managing scientific literature, references and citations"
9 HOMEPAGE="http://www.refbase.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11 LICENSE="GPL-2"
12 KEYWORDS="~x86 ~amd64"
13 IUSE=""
14 DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
15         dev-lang/php[mysql,session]
16         app-admin/webapp-config
17         app-text/bibutils"
18 RDEPEND="${DEPEND}"
19
20 need_apache
21
22 pkg_setup() {
23         webapp_pkg_setup
24 }
25
26 src_install () {
27         webapp_src_preinst
28
29         DOCS="AUTHORS BUGS ChangeLog NEWS README TODO UPDATE"
30         dodoc ${DOCS}
31         # Don't install docs to webroot
32         rm -f ${DOCS} COPYING INSTALL
33
34         cp -R * "${D}"${MY_HTDOCSDIR}
35
36         webapp_configfile ${MY_HTDOCSDIR}/initialize
37         webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
38
39         webapp_src_install
40 }