dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / app-text / rarian / rarian-0.8.1-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils ltprune
7
8 DESCRIPTION="A documentation metadata library"
9 HOMEPAGE="https://rarian.freedesktop.org/"
10 SRC_URI="https://${PN}.freedesktop.org/Releases/${P}.tar.gz
11         https://dev.gentoo.org/~eva/distfiles/${PN}/${P}-r3-patches.tar.xz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
16 IUSE="static-libs"
17
18 RDEPEND="
19         dev-libs/libxslt
20         dev-libs/tinyxml
21         || (
22                 sys-apps/util-linux
23                 app-misc/getopt )
24 "
25 DEPEND="${RDEPEND}
26         !<app-text/scrollkeeper-9999
27 "
28
29 DOCS=( ChangeLog NEWS README )
30
31 PATCHES=(
32         "${WORKDIR}"/0001-Fix-uri-of-omf-files-produced-by-rarian-sk-preinstal.patch
33         "${WORKDIR}"/0002-Allow-building-against-system-copy-of-tinyxml.patch
34         "${WORKDIR}"/0003-Allow-to-specify-only-the-prefix-of-an-info-page-e.g.patch
35         "${WORKDIR}"/0004-Fix-a-crash-when-opening-files-without-dots-in-their.patch
36         "${WORKDIR}"/0005-Make-librarian-obey-to-LC_MESSAGES.patch
37         "${WORKDIR}"/0006-Fix-m4-syntax-so-that-autoreconf-doesn-t-break.patch
38         "${WORKDIR}"/0007-Remove-the-nonexistent-dist-gzip-Automake-option.patch
39         "${WORKDIR}"/0008-Fix-OMF-category-parsing.patch
40         "${WORKDIR}"/0009-Allow-the-getopt-command-to-be-customized-at-configu.patch
41 )
42
43 src_prepare() {
44         default
45         eautoreconf
46 }
47
48 src_configure() {
49         local myconf=()
50         # https://bugs.gentoo.org/show_bug.cgi?id=409811
51         # https://bugs.freedesktop.org/show_bug.cgi?id=53264
52         if ! has_version sys-apps/util-linux; then
53                 myconf=( --with-getopt=getopt-long )
54         fi
55
56         econf \
57                 --localstatedir="${EPREFIX}"/var \
58                 $(use_enable static-libs static) \
59                 ${myconf[@]}
60 }
61
62 src_install() {
63         default
64         prune_libtool_files --all
65 }