dev-qt/qtwayland: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-text / pinfo / pinfo-99999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools flag-o-matic git-r3
6
7 DESCRIPTION="Hypertext info and man viewer based on (n)curses"
8 HOMEPAGE="https://github.com/baszoetekouw/pinfo"
9 EGIT_REPO_URI="https://github.com/baszoetekouw/pinfo.git"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS=""
14 IUSE="nls readline"
15
16 RDEPEND="
17         sys-libs/ncurses:0=
18         sys-libs/readline:0=
19         nls? ( virtual/libintl )
20 "
21
22 DEPEND="
23         ${RDEPEND}
24         sys-apps/texinfo
25         sys-devel/bison
26         virtual/pkgconfig
27         nls? ( sys-devel/gettext )
28 "
29 PATCHES=(
30         "${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch
31         "${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch
32         "${FILESDIR}"/${PN}-0.6.13-fno-common.patch
33 )
34
35 src_prepare() {
36         default
37         eautoreconf
38 }
39
40 src_configure() {
41         append-cflags -D_BSD_SOURCE -D_DEFAULT_SOURCE # sbrk()
42
43         econf \
44                 $(use_with readline) \
45                 $(use_enable nls)
46 }
47
48 src_install() {
49         emake DESTDIR="${D}" sysconfdir="${EPREFIX}/etc" install
50 }