app-i18n/ibus-handwrite: Remove old
[gentoo.git] / app-text / nfoview / nfoview-1.27.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1 xdg-utils
9
10 if [[ ${PV} == *9999 ]] ; then
11         EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
12         inherit git-r3
13 else
14         SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 DESCRIPTION="Simple viewer for NFO files, which are ASCII art in the CP437 codepage"
19 HOMEPAGE="https://otsaloma.io/nfoview/"
20
21 LICENSE="GPL-3+"
22 SLOT="0"
23 IUSE=""
24
25 BDEPEND="${PYTHON_DEPS}
26         sys-devel/gettext"
27 DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
28 RDEPEND="${DEPEND}
29         media-fonts/terminus-font"
30
31 pkg_postinst() {
32         xdg_icon_cache_update
33         xdg_desktop_database_update
34 }
35
36 pkg_postrm() {
37         xdg_icon_cache_update
38         xdg_desktop_database_update
39 }