app-text/poppler: Drop 0.88.0 (r0)
[gentoo.git] / app-text / libwpd / libwpd-0.10.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="WordPerfect Document import/export library"
7 HOMEPAGE="http://libwpd.sf.net"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
9
10 LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
11 SLOT="0.10"
12 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 x86"
13 IUSE="doc +tools"
14
15 RDEPEND="dev-libs/librevenge"
16 DEPEND="${RDEPEND}
17         dev-libs/boost
18 "
19 BDEPEND="
20         virtual/pkgconfig
21         doc? ( app-doc/doxygen )
22 "
23
24 PATCHES=( "${FILESDIR}/${P}-gcc-4.8.patch" )
25
26 src_configure() {
27         local myeconfargs=(
28                 --program-suffix=-${SLOT}
29                 --disable-static
30                 $(use_with doc docs)
31                 $(use_enable tools)
32         )
33         econf "${myeconfargs[@]}"
34 }
35
36 src_install() {
37         default
38         find "${D}" -name '*.la' -delete || die
39 }