app-text/libmspub: use HTTPS for freedesktop.org
[gentoo.git] / app-text / libmspub / libmspub-0.1.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
7 [[ ${PV} == 9999 ]] && inherit autotools git-r3
8
9 DESCRIPTION="Library parsing Microsoft Publisher documents"
10 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
11 [[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15
16 # Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
17 [[ ${PV} == 9999 ]] || \
18 KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
19
20 IUSE="doc static-libs"
21
22 RDEPEND="
23         dev-libs/icu:=
24         dev-libs/librevenge
25         sys-libs/zlib
26 "
27 DEPEND="${RDEPEND}
28         dev-libs/boost
29         sys-devel/libtool
30         virtual/pkgconfig
31         doc? ( app-doc/doxygen )
32 "
33
34 src_prepare() {
35         default
36         [[ -d m4 ]] || mkdir "m4"
37         [[ ${PV} == 9999 ]] && eautoreconf
38 }
39
40 src_configure() {
41         econf \
42                 --disable-werror \
43                 $(use_with doc docs) \
44                 $(use_enable static-libs static)
45 }
46
47 src_install() {
48         default
49         find "${D}" -name '*.la' -delete || die
50 }