app-text/liblangtag: 0.6.2 version bump
[gentoo.git] / app-text / liblangtag / liblangtag-0.6.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit eutils xdg-utils
8
9 DESCRIPTION="An interface library to access tags for identifying languages"
10 HOMEPAGE="https://tagoh.bitbucket.org/liblangtag/"
11 SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
12
13 LICENSE="|| ( LGPL-3 MPL-2.0 )"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ppc ~x86"
16 IUSE="debug doc introspection static-libs test"
17
18 RDEPEND="
19         dev-libs/libxml2
20         introspection? ( dev-libs/gobject-introspection )
21 "
22 DEPEND="${RDEPEND}
23         sys-devel/gettext
24         doc? ( dev-util/gtk-doc )
25         introspection? ( dev-libs/gobject-introspection-common )
26         test? ( dev-libs/check )
27 "
28
29 # Upstream expect liblangtag to be installed when one runs tests...
30 RESTRICT="test"
31
32 src_prepare() {
33         default
34         xdg_environment_reset
35         if [[ -d docs/html ]]; then
36                 rm -r docs/html || die "Failed to remove existing gtk-doc"
37         fi
38 }
39
40 src_configure() {
41         econf \
42                 $(use_enable debug) \
43                 $(use_enable doc gtk-doc) \
44                 $(use_enable introspection) \
45                 $(use_enable static-libs static) \
46                 $(use_enable test)
47 }
48
49 src_install() {
50         default
51         prune_libtool_files --all
52 }