app-text/liblangtag: 0.6.2 version bump
[gentoo.git] / app-text / liblangtag / liblangtag-0.5.6.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit xdg-utils autotools-utils
8
9 DESCRIPTION="An interface library to access tags for identifying languages"
10 HOMEPAGE="https://tagoh.bitbucket.org/liblangtag/"
11 SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
12
13 LICENSE="|| ( LGPL-3 MPL-1.1 )"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~ppc x86"
16 IUSE="introspection static-libs test"
17
18 RDEPEND="
19         dev-libs/glib
20         dev-libs/libxml2
21         introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
22 DEPEND="${RDEPEND}
23         dev-libs/gobject-introspection-common
24         sys-devel/gettext
25         test? ( dev-libs/check )"
26
27 # Upstream expect liblangtag to be installed when one runs tests...
28 RESTRICT="test"
29
30 PATCHES=( "${FILESDIR}/${PN}-0.5.6-musl.patch" )
31
32 src_configure() {
33         xdg_environment_reset
34         local myeconfargs=(
35                 $(use_enable introspection)
36                 $(use_enable test)
37         )
38         autotools-utils_src_configure
39 }
40
41 src_install() {
42         autotools-utils_src_install
43         prune_libtool_files --all
44 }