app-text/libabw: Fix build with boost-1.59, bug 575524
[gentoo.git] / app-text / libabw / libabw-0.1.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit base eutils
8
9 DESCRIPTION="Library parsing abiword documents"
10 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
11 SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
12
13 LICENSE="MPL-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm x86"
16 IUSE="doc static-libs"
17
18 RDEPEND="
19         dev-libs/librevenge
20         dev-libs/libxml2
21         sys-libs/zlib
22 "
23 DEPEND="${RDEPEND}
24         >=dev-libs/boost-1.46
25         sys-devel/libtool
26         virtual/pkgconfig
27         doc? ( app-doc/doxygen )
28 "
29
30 PATCHES=(
31         # from git master
32         "${FILESDIR}/${PN}-0.1.1-dereference-before-null-check.patch"
33         "${FILESDIR}/${PN}-0.1.1-do-not-let-AbiDocument_parse-throw.patch"
34         "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
35 )
36
37 src_configure() {
38         econf \
39                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
40                 --disable-werror \
41                 $(use_enable static-libs static) \
42                 $(use_with doc docs)
43 }
44
45 src_install() {
46         default
47         prune_libtool_files --all
48 }