sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / app-text / lesspipe / lesspipe-1.83.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 DESCRIPTION="a preprocessor for less"
7 HOMEPAGE="https://github.com/wofr06/lesspipe"
8 SRC_URI="https://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
13 IUSE=""
14
15 DEPEND="dev-lang/perl"
16 RDEPEND="${DEPEND}
17         !<sys-apps/less-483-r1"
18
19 src_configure() {
20         # Not an autoconf script.
21         ./configure --fixed || die
22 }
23
24 src_compile() {
25         # Nothing to build.
26         :
27 }
28
29 src_install() {
30         emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
31         dodoc ChangeLog README TODO
32 }
33
34 pkg_preinst() {
35         if [[ -z ${REPLACING_VERSIONS} ]] ; then
36                 elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
37                 elog "The latter is the Gentoo-specific version.  Make sure to update your"
38                 elog "LESSOPEN environment variable if you wish to use this copy."
39         fi
40 }