app-text/lesspipe: dropped ~hppa-hpux ~ia64-hpux ~ia64-linux ~x64-freebsd ~x86-freebs...
[gentoo.git] / app-text / lesspipe / lesspipe-1.83.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 DESCRIPTION="a preprocessor for less"
8 HOMEPAGE="https://github.com/wofr06/lesspipe"
9 SRC_URI="https://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE=""
15
16 DEPEND="dev-lang/perl"
17 RDEPEND="${DEPEND}
18         !<sys-apps/less-483-r1"
19
20 src_configure() {
21         # Not an autoconf script.
22         ./configure --fixed || die
23 }
24
25 src_compile() {
26         # Nothing to build.
27         :
28 }
29
30 src_install() {
31         emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
32         dodoc ChangeLog README TODO
33 }
34
35 pkg_preinst() {
36         if [[ -z ${REPLACING_VERSIONS} ]] ; then
37                 elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
38                 elog "The latter is the Gentoo-specific version.  Make sure to update your"
39                 elog "LESSOPEN environment variable if you wish to use this copy."
40         fi
41 }