www-plugins/chrome-binary-plugins: automated update
[gentoo.git] / app-text / lcdf-typetools / lcdf-typetools-2.107.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs flag-o-matic
7
8 DESCRIPTION="Font utilities for eg manipulating OTF"
9 SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
10 HOMEPAGE="http://www.lcdf.org/type/#typetools"
11 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
12 SLOT="0"
13 LICENSE="GPL-2"
14 IUSE="+kpathsea"
15
16 RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19
20 src_configure() {
21         use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
22         econf $(use_with kpathsea)
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install
27         dodoc NEWS.md README.md ONEWS
28 }