app-text/kbibtex: 0.6.2 version bump, add USE=webkit
[gentoo.git] / app-text / kbibtex / kbibtex-0.6.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 WEBKIT_REQUIRED="optional"
8 inherit kde4-base
9
10 DESCRIPTION="BibTeX editor by KDE to edit bibliographies used with LaTeX"
11 HOMEPAGE="http://home.gna.org/kbibtex/"
12 SRC_URI="http://download.gna.org/${PN}/0.6/${P}.tar.xz"
13
14 LICENSE="GPL-2"
15 SLOT="4"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug"
18
19 DEPEND="
20         app-text/poppler[qt4]
21         dev-libs/libxml2
22         dev-libs/libxslt
23         dev-libs/qoauth:0
24         virtual/tex-base
25         x11-libs/libqxt
26 "
27 RDEPEND="${DEPEND}
28         dev-tex/bibtex2html
29 "
30
31 PATCHES=( "${FILESDIR}/${P}-webkit.patch" )
32
33 src_configure() {
34         local mycmakeargs=(
35                 -DWITH_QTWEBKIT=$(usex webkit)
36         )
37
38         kde4-base_src_configure
39 }