virtual/perl-Compress-Raw-Bzip2: keyword ~riscv
[gentoo.git] / app-text / html-xml-utils / html-xml-utils-7.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit multilib-minimal
7
8 DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
9 SRC_URI="http://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
10 HOMEPAGE="http://www.w3.org/Tools/HTML-XML-utils/"
11
12 LICENSE="W3C"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x86-macos"
15
16 RESTRICT="test"
17
18 RDEPEND="net-misc/curl"
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         default
23         sed -e "/doc_DATA = COPYING/d" -i Makefile.in || die
24 }
25
26 multilib_src_configure() {
27         ECONF_SOURCE="${S}" econf
28 }
29
30 src_compile() {
31         multilib-minimal_src_compile
32 }
33
34 src_install() {
35         multilib-minimal_src_install
36 }