app-text/gtkspell: x86 stable wrt bug #717144
[gentoo.git] / app-text / gtkspell / gtkspell-2.0.16-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils
7
8 DESCRIPTION="Spell checking widget for GTK"
9 HOMEPAGE="http://gtkspell.sourceforge.net/"
10 # gtkspell doesn't use sourceforge mirroring system it seems.
11 SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="2"
15 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
16 IUSE=""
17
18 RDEPEND="x11-libs/gtk+:2
19         >=app-text/enchant-1.1.6:0"
20 DEPEND="${RDEPEND}
21         dev-util/gtk-doc-am
22         >=dev-util/intltool-0.35.0
23         virtual/pkgconfig"
24
25 DOCS=( AUTHORS ChangeLog README ) # NEWS file is empty
26
27 src_prepare() {
28         default
29
30         # Fix intltoolize broken file, see upstream #577133
31         sed -i -e "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" po/Makefile.in.in || die
32 }
33
34 src_configure() {
35         econf --disable-static --disable-gtk-doc
36 }
37
38 src_install() {
39         default
40         find "${D}" -name '*.la' -type f -delete || die
41 }