Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / app-text / groonga-normalizer-mysql / groonga-normalizer-mysql-1.1.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils autotools
7
8 DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
9 HOMEPAGE="http://groonga.org/"
10 SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="app-text/groonga"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20 DOCS=( README.md )
21
22 src_prepare() {
23         eautoreconf
24 }
25
26 src_configure() {
27         # ruby is only uses for tests
28         econf \
29                 --without-ruby \
30                 --docdir="${EROOT}usr/share/doc/${P}"
31 }
32
33 src_install() {
34         default
35
36         prune_libtool_files
37         rm -r "${D}usr/share/doc/${PN}" || die
38 }