app-text/txt2tags: amd64 stable wrt bug #565662
[gentoo.git] / app-text / expander / expander-2.0.5-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Expander is a utility that acts as a filter for text editors"
10 HOMEPAGE="http://www.nedit.org"
11 SRC_URI="ftp://ftp.nedit.org/pub/contrib/misc/nedit_expander_kit_2.05.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
16 IUSE=""
17
18 S=${WORKDIR}/${PN}
19
20 src_prepare() {
21         epatch "${FILESDIR}"/${P}-gentoo.patch
22 }
23
24 src_compile() {
25         emake -C src CC=$(tc-getCC)
26 }
27
28 src_install() {
29         cd src
30         dobin expander boxcomment align_columns align_comments where_is
31         dosym /usr/bin/boxcomment /usr/bin/unboxcomment
32
33         insinto /usr/share/${P}
34         doins "${S}"/service
35         for x in defs macros misc templates ; do
36                 insinto /usr/share/${P}/${x}
37                 doins "${S}"/${x}/*
38         done
39
40         cd "${S}"/docs
41         doman *.1
42
43         cd "${S}"
44         dodoc ChangeLog INSTALL README USAGE
45 }
46
47 pkg_postinst() {
48         elog
49         elog "Instructions for using expander with NEdit are in /usr/share/doc/${PF}/INSTALL"
50         elog "Macro, definition and template files can be found in /usr/share/${P}"
51         elog
52 }