app-text/dvisvgm: 2.3.1
[gentoo.git] / app-text / dvisvgm / dvisvgm-2.3.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs flag-o-matic
7
8 DESCRIPTION="Converts DVI files to SVG"
9 HOMEPAGE="http://dvisvgm.bplaced.net/"
10 SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
15 IUSE="test"
16 # Tests don't work from $WORKDIR: kpathsea tries to search in relative
17 # directories from where the binary is executed.
18 # We cannot really use absolute paths in the kpathsea configuration since that
19 # would make it harder for prefix installs.
20 RESTRICT="test"
21
22 # TODO unbundle app-arch/brotli
23 RDEPEND="virtual/tex-base
24         app-text/ghostscript-gpl
25         dev-libs/kpathsea:=
26         >=media-gfx/potrace-1.10-r1
27         media-libs/freetype:2
28         dev-libs/kpathsea
29         sys-libs/zlib"
30 DEPEND="${RDEPEND}
31         app-text/xmlto
32         app-text/asciidoc
33         dev-libs/libxslt
34         virtual/pkgconfig
35         test? ( dev-cpp/gtest )"
36
37 src_configure() {
38         local myargs=(
39                 --without-ttfautohint
40         )
41         econf "${myargs[@]}"
42 }