5fcc06a6cc66bd1916979f5b3df47d5aeb5552ba
[gentoo.git] / app-text / dvisvgm / dvisvgm-2.1.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs flag-o-matic
7
8 DESCRIPTION="Converts DVI files to SVG"
9 HOMEPAGE="http://dvisvgm.bplaced.net/"
10 SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
15 IUSE="test"
16 # Tests don't work from $WORKDIR: kpathsea tries to search in relative
17 # directories from where the binary is executed.
18 # We cannot really use absolute paths in the kpathsea configuration since that
19 # would make it harder for prefix installs.
20 RESTRICT="test"
21
22 RDEPEND="virtual/tex-base
23         app-text/ghostscript-gpl
24         >=media-gfx/potrace-1.10-r1
25         media-libs/freetype:2
26         dev-libs/kpathsea
27         sys-libs/zlib"
28 DEPEND="${RDEPEND}
29         app-text/xmlto
30         app-text/asciidoc
31         dev-libs/libxslt
32         virtual/pkgconfig
33         test? ( dev-cpp/gtest )"
34
35 src_configure() {
36         has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
37         default
38 }