41099fb295a6272901f3f560f5196df69432ab6c
[gentoo.git] / app-text / dvisvgm / dvisvgm-1.2.1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 DESCRIPTION="Converts DVI files to SVG"
8 HOMEPAGE="http://dvisvgm.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
14 IUSE="test"
15 # Tests don't work from $WORKDIR: kpathsea tries to search in relative
16 # directories from where the binary is executed.
17 # We cannot really use absolute paths in the kpathsea configuration since that
18 # would make it harder for prefix installs.
19 RESTRICT="test"
20
21 RDEPEND="virtual/tex-base
22         app-text/ghostscript-gpl
23         >=media-gfx/potrace-1.10-r1
24         media-libs/freetype:2
25         sys-libs/zlib"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig
28         test? ( dev-cpp/gtest )"