Use https by default
[gentoo.git] / app-text / csvfix / csvfix-1.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit eutils toolchain-funcs versionator
8
9 MY_PV="$(delete_all_version_separators)"
10 DESCRIPTION="A stream editor for manipulating CSV files"
11 HOMEPAGE="http://code.google.com/p/csvfix/"
12 SRC_URI="https://dev.gentoo.org/~radhermit/dist/${P}.tar.bz2
13         doc? ( http://csvfix.googlecode.com/files/CSVfix_man_html_${MY_PV}0.zip )"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 RDEPEND="dev-libs/expat"
21 DEPEND="${RDEPEND}
22         doc? ( app-arch/unzip )"
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${P}-make.patch
26         epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
27
28         edos2unix $(find csvfix/tests -type f)
29 }
30
31 src_compile() {
32         emake CC="$(tc-getCXX)" AR="$(tc-getAR)" lin
33 }
34
35 src_test() {
36         cd ${PN}/tests
37         chmod +x run1 runtests
38         ./runtests || die "tests failed"
39 }
40
41 src_install() {
42         dobin csvfix/bin/csvfix
43         use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}/*
44 }