e0947974882f3d78f037caf1e2d980e63bbe5ccf
[gentoo.git] / app-text / convmv / convmv-2.03.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="convert filenames to utf8 or any other charset"
7 HOMEPAGE="https://j3e.de/linux/convmv"
8 SRC_URI="https://j3e.de/linux/${PN}/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
13 IUSE=""
14
15 DEPEND="dev-lang/perl"
16 RDEPEND="${DEPEND}"
17
18 src_prepare() {
19         default
20         sed -i -e "1s|#!/usr|#!${EPREFIX}/usr|" convmv || die
21 }
22
23 src_install() {
24         emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
25         dodoc CREDITS Changes TODO VERSION
26 }
27
28 src_test() {
29         unpack ./testsuite.tar
30
31         cd "${S}"/suite
32         ./dotests.sh || die "Tests failed"
33 }