acct-group/clair: add clair group
[gentoo.git] / app-text / bibletime / bibletime-2.11.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils
7
8 DESCRIPTION="Qt Bible study application using the SWORD library"
9 HOMEPAGE="http://www.bibletime.info/"
10 SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="debug"
16
17 # bug 313657
18 RESTRICT="test"
19
20 RDEPEND="
21         >=app-text/sword-1.7.0
22         dev-cpp/clucene
23         dev-qt/qtcore:5
24         dev-qt/qtgui:5
25         dev-qt/qtprintsupport:5
26         dev-qt/qtwebchannel:5
27         dev-qt/qtwebengine:5
28         dev-qt/qtwidgets:5
29         dev-qt/qtxml:5
30 "
31 DEPEND="${RDEPEND}
32         dev-libs/boost
33         dev-libs/icu:=
34         dev-qt/linguist-tools:5
35         dev-qt/qttest:5
36         net-misc/curl
37         sys-libs/zlib
38 "
39
40 DOCS=( ChangeLog README.md )
41
42 src_prepare() {
43         cmake-utils_src_prepare
44
45         sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
46             -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
47 }