app-text/docx2txt: drop old EAPI
[gentoo.git] / app-text / agrep / agrep-2.04-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A tool for the fast searching of text allowing for errors in the search pattern"
9 HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
10 SRC_URI="ftp://ftp.cs.arizona.edu/${PN}/${P}.tar.Z"
11
12 LICENSE="AGREP"
13 SLOT="0"
14 KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86 ~ppc-macos ~sparc-solaris"
15
16 RDEPEND="
17         !dev-libs/tre
18         !dev-ruby/amatch
19         !app-misc/glimpse"
20
21 DOCS=( README agrep.algorithms agrep.chronicle COPYRIGHT contribution.list )
22
23 src_compile() {
24         sed -i \
25                 -e 's/^CFLAGS.*//' \
26                 -e "s:\$(CFLAGS):& \$(LDFLAGS) :" Makefile || die
27         tc-export CC
28         emake
29 }
30
31 src_install() {
32         dobin "${PN}"
33         doman "${PN}.1"
34         einstalldocs
35 }