app-text/docbook-sgml-utils: x86 stable (bug #647676)
[gentoo.git] / app-text / XML-Schema-learner / XML-Schema-learner-1.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
7 HOMEPAGE="https://github.com/kore/${PN}"
8 SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="test"
14
15 # PHP dependency can be inferred from .travis.yml in the repository.
16 # The necessary USE flags on the other hand were found the hard way.
17 #
18 # The dependencies here aren't as expressive as they should be. What we
19 # really want is for php[...] to apply to everything in PHP_TARGETS, and
20 # for those interpreters (the ones in PHP_TARGETS) to be used to run the
21 # test suite.
22 #
23 # See bug #497606.
24 #
25 RDEPEND="dev-lang/php:*[cli,xml,xmlreader]"
26 DEPEND="test? ( ${RDEPEND}
27                                 dev-php/phpunit )"
28
29 src_compile() {
30         # Don't run make, the default target is 'check'.
31         :
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" PREFIX="/usr" install
36         dodoc README.rst
37 }