app-shells/yash: amd64/x86 stable
[gentoo.git] / app-shells / yash / yash-2.48.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 PLOCALES="en ja"
6
7 inherit flag-o-matic l10n toolchain-funcs
8
9 DESCRIPTION="Yash is a POSIX-compliant command line shell"
10 HOMEPAGE="https://yash.osdn.jp/"
11 SRC_URI="mirror://sourceforge.jp/${PN}/70439/${P}.tar.xz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="nls test"
17
18 RDEPEND="sys-libs/ncurses:=
19         nls? ( virtual/libintl )"
20 DEPEND="${RDEPEND}
21         nls? ( sys-devel/gettext )
22         test? ( sys-apps/ed )"
23
24 src_configure() {
25         append-cflags -std=c99
26
27         sh ./configure \
28                 --prefix="${EPREFIX}"/usr \
29                 $(use_enable nls) \
30                 CC=$(tc-getCC) \
31                 LINGUAS="$(l10n_get_locales | sed "s/en/en@quot en@boldquot/")" \
32                 || die
33 }