app-shells/dash: ppc stable wrt bug #720882
[gentoo.git] / app-shells / thefuck / thefuck-3.27.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Magnificent app which corrects your previous console command"
11 HOMEPAGE="https://github.com/nvbn/thefuck"
12 SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/psutil[${PYTHON_USEDEP}]
22         dev-python/six[${PYTHON_USEDEP}]
23         dev-python/decorator[${PYTHON_USEDEP}]
24         dev-python/colorama[${PYTHON_USEDEP}]
25         dev-python/pyte[${PYTHON_USEDEP}]"
26 DEPEND="
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 ${RDEPEND}
30                 dev-python/pytest[${PYTHON_USEDEP}]
31                 dev-python/pytest-mock[${PYTHON_USEDEP}]
32         )"
33
34 python_prepare_all() {
35         sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
36
37         distutils-r1_python_prepare_all
38 }
39
40 python_test() {
41         py.test || die
42 }