app-shells/thefuck: version bump to 3.27 and EAPI=7.
[gentoo.git] / app-shells / thefuck / thefuck-3.26.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Magnificent app which corrects your previous console command"
11 HOMEPAGE="https://github.com/nvbn/thefuck"
12 SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18
19 RDEPEND="
20         dev-python/psutil[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]
22         dev-python/decorator[${PYTHON_USEDEP}]
23         dev-python/colorama[${PYTHON_USEDEP}]
24         dev-python/pyte[${PYTHON_USEDEP}]"
25 DEPEND="
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         test? (
28                 ${RDEPEND}
29                 dev-python/pytest[${PYTHON_USEDEP}]
30                 dev-python/pytest-mock[${PYTHON_USEDEP}]
31         )"
32
33 python_prepare_all() {
34         sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
35
36         distutils-r1_python_prepare_all
37 }
38
39 python_test() {
40         py.test || die
41 }