app-shells/thefuck: Version bump to 3.18
[gentoo.git] / app-shells / thefuck / thefuck-3.16.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=(python{2_7,3_4,3_5})
6
7 inherit distutils-r1
8
9 DESCRIPTION="Magnificent app which corrects your previous console command"
10 HOMEPAGE="https://github.com/nvbn/thefuck"
11 SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 KEYWORDS="~amd64 ~x86"
13
14 LICENSE="MIT"
15 SLOT="0"
16 IUSE="test"
17
18 RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
19         dev-python/six[${PYTHON_USEDEP}]
20         dev-python/decorator[${PYTHON_USEDEP}]
21         dev-python/colorama[${PYTHON_USEDEP}]
22         $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)"
23 DEPEND="test? ( ${RDEPEND}
24         dev-python/pytest[${PYTHON_USEDEP}]
25         dev-python/pytest-mock[${PYTHON_USEDEP}] )
26         dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 src_prepare() {
29         sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
30         distutils-r1_src_prepare
31 }
32
33 python_test() {
34         py.test || die
35 }