app-shells/thefuck: depend on virtual/python-pathlib
[gentoo.git] / app-shells / thefuck / thefuck-3.10.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=(python{2_7,3_4})
7
8 inherit distutils-r1
9
10 DESCRIPTION="Magnificent app which corrects your previous console command"
11 HOMEPAGE="https://github.com/nvbn/thefuck"
12 SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13 KEYWORDS="~amd64 ~x86"
14
15 LICENSE="MIT"
16 SLOT="0"
17 IUSE="test"
18
19 RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]
20         dev-python/psutil[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]
22         dev-python/decorator[${PYTHON_USEDEP}]
23         dev-python/colorama[${PYTHON_USEDEP}]"
24 DEPEND="test? ( ${RDEPEND}
25         dev-python/pytest[${PYTHON_USEDEP}] )
26         dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 src_prepare() {
29         sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
30         distutils-r1_src_prepare
31 }
32
33 python_test() {
34         py.test || die
35 }