app-shells/powerline: initial add
[gentoo.git] / app-shells / powerline / powerline-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="The ultimate statusline/prompt utility."
10 HOMEPAGE="https://github.com/powerline/powerline"
11 if [[ ${PV} == 9999 ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/powerline/powerline"
14         EGIT_BRANCH="develop"
15 else
16         SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
17         KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
18 fi
19 S="${WORKDIR}/${PN}-status-${PV}"
20
21 LICENSE="Apache-2.0"
22 SLOT="0"
23 IUSE="test"
24
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
26 RDEPEND=""