Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / app-shells / pdmenu / pdmenu-1.3.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="A simple console menu program"
10 HOMEPAGE="http://joeyh.name/code/pdmenu/"
11 SRC_URI="mirror://debian/pool/main/p/${PN}/pdmenu_${PV}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 mips x86"
16 IUSE="nls gpm examples"
17
18 DEPEND="
19         sys-libs/slang
20         gpm? ( sys-libs/gpm )
21         nls? ( sys-devel/gettext )"
22
23 S=${WORKDIR}/${PN}
24
25 RESTRICT="test"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${PN}-impl-dec.patch
29         sed \
30                 -e 's:\(-o pdmenu\):$(LDFLAGS) \1:g' \
31                 -i Makefile || die
32 }
33
34 src_configure() {
35         CC=$(tc-getCC) econf \
36                 $(use_with gpm) \
37                 $(use_enable nls)
38 }
39
40 src_compile() {
41         emake CC=$(tc-getCC) || die
42 }
43
44 src_install() {
45         dobin "${PN}"
46         dodoc doc/ANNOUNCE doc/BUGS doc/TODO
47         use examples && dodoc -r examples
48         mv "doc/${PN}.man" "doc/${PN}.1" || die
49         mv "doc/${PN}rc.man" "doc/${PN}rc.5" || die
50         doman "doc/${PN}.1" "doc/${PN}rc.5"
51
52 }
53
54 pkg_postinst() {
55         ewarn "Note this part from man page: Security warning! Any exec command"
56         ewarn "that uses the 'edit' flag will be a security hole. The user need"
57         ewarn "only to enter text with a ';' in it, and they can run an"
58         ewarn "arbitrary command after the semicolon!"
59 }