dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-shells / mpibash / mpibash-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools multilib
7
8 if [[ ${PV} = 9999 ]]; then
9         EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
10         inherit git-r3
11         KEYWORDS=""
12 else
13         SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
14         KEYWORDS="~amd64"
15 fi
16
17 DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
18 HOMEPAGE="https://github.com/lanl/MPI-Bash"
19
20 LICENSE="GPL-3"
21 SLOT="0"
22 IUSE="examples"
23
24 DEPEND="virtual/mpi
25         >=app-shells/bash-4.2:0[plugins]
26         sys-cluster/libcircle"
27 RDEPEND="${DEPEND}"
28
29 src_prepare() {
30         default
31         [[ ${PV} != 9999 ]] || eautoreconf
32 }
33
34 src_configure() {
35         econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
36                 --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
37 }
38
39 src_install() {
40         default
41         sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
42         use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
43 }