media-sound/sonata: 1.7_beta1_p20200212 version bump
[gentoo.git] / app-shells / mpibash / mpibash-1.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-utils multilib
7
8 if [[ ${PV} = 9999 ]]; then
9         EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
10         inherit git-r3
11         KEYWORDS=""
12         AUTOTOOLS_AUTORECONF=1
13 else
14         SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
15         KEYWORDS="~amd64"
16 fi
17
18 DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
19 HOMEPAGE="https://github.com/lanl/MPI-Bash"
20
21 LICENSE="GPL-3"
22 SLOT="0"
23 IUSE="examples"
24
25 DEPEND="virtual/mpi
26         >=app-shells/bash-4.2[plugins]
27         sys-cluster/libcircle"
28 RDEPEND="${DEPEND}"
29
30 src_configure() {
31         local myeconfargs=(
32                 --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
33                 --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
34         )
35         autotools-utils_src_configure
36 }
37
38 src_install() {
39         autotools-utils_src_install
40         sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
41         use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
42 }