Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / app-shells / mpibash / mpibash-1.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools-utils multilib
8
9 if [[ ${PV} = 9999 ]]; then
10         EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git https://github.com/losalamos/MPI-Bash.git"
11         inherit git-r3
12         KEYWORDS=""
13         AUTOTOOLS_AUTORECONF=1
14 else
15         SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
16         KEYWORDS="~amd64"
17 fi
18
19 DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
20 HOMEPAGE="https://github.com/losalamos/MPI-Bash"
21
22 LICENSE="GPL-3"
23 SLOT="0"
24 IUSE="examples"
25
26 DEPEND="virtual/mpi
27         >=app-shells/bash-4.2[plugins]
28         sys-cluster/libcircle"
29 RDEPEND="${DEPEND}"
30
31 src_configure() {
32         local myeconfargs=(
33                 --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
34                 --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
35         )
36         autotools-utils_src_configure
37 }
38
39 src_install() {
40         autotools-utils_src_install
41         sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
42         use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
43 }