app-shells/localshell: Stable for amd64+ppc+x86. Keyword for ppc64.
[gentoo.git] / app-shells / localshell / localshell-1.3.4-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit base eutils
8
9 DESCRIPTION="Localshell allows per-user/group local control of shell execution"
10 HOMEPAGE="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary"
11 SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86 ~ppc64"
16 IUSE=""
17
18 src_configure() {
19         # this is a shell, it needs to be in /bin
20         econf --bindir=/bin --sysconfdir=/etc
21 }
22
23 src_install() {
24         emake install DESTDIR="${D}" || die "emake install failed"
25         rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
26 }
27
28 pkg_postinst() {
29         elog "Remember to add /bin/localshell to /etc/shells and create"
30         elog "/etc/localshell.conf based on the included configuration examples"
31 }