app-shells/ksh: bump
[gentoo.git] / app-shells / ksh / ksh-93.20180215.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit meson prefix
7
8 DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
9 HOMEPAGE="http://www.kornshell.com/"
10
11 COMMIT="e3dd5b1a4b1bf58a018bbd9c8626b15113b72717"
12 SRC_URI="https://github.com/att/ast/archive/${COMMIT}/${P}.tar.gz"
13
14 LICENSE="CPL-1.0 EPL-1.0"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
17 IUSE=""
18
19 RDEPEND="!app-shells/pdksh"
20
21 S="${WORKDIR}/ast-${COMMIT}"
22
23 PATCHES=(
24         "${FILESDIR}"/ksh-prefix-r1.patch
25 )
26
27 src_prepare() {
28         default
29         eprefixify src/cmd/ksh93/data/msg.c
30 }
31
32 src_install() {
33         meson_src_install
34         dodir /bin
35         mv "${ED%/}"{/usr,}/bin/ksh || die
36 }