app-shells/fish: version bump to 2.6.0
[gentoo.git] / app-shells / fish / fish-2.6.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="fish is the Friendly Interactive SHell"
7 HOMEPAGE="http://fishshell.com/"
8 SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${PV}/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
13 IUSE="nls"
14
15 RDEPEND="
16         >=dev-libs/libpcre2-10.21[pcre32]
17         sys-libs/ncurses:0=
18 "
19 DEPEND="
20         ${RDEPEND}
21         sys-devel/bc
22         nls? ( sys-devel/gettext )
23 "
24
25 src_configure() {
26         # Set things up for fish to be a default shell.
27         # It has to be in /bin in case /usr is unavailable.
28         # Also, all of its utilities have to be in /bin.
29         econf \
30                 docdir="${EPREFIX}"/usr/share/doc/${PF} \
31                 --bindir="${EPREFIX}"/bin \
32                 --without-included-pcre2 \
33                 $(use_with nls gettext)
34 }
35
36 src_test() {
37         if has_version ~${CATEGORY}/${P} ; then
38                 emake test
39         else
40                 ewarn "The test suite only works when the package is already installed"
41         fi
42 }
43
44 pkg_postinst() {
45         elog "fish is now installed on your system."
46         elog "To run fish, type 'fish' in your terminal."
47         elog
48         elog "It is advised not to set fish as a default login shell."
49         elog "see bug #545830 for more details."
50         elog "Executing fish using ~/.bashrc is an alternative"
51         elog "see https://wiki.gentoo.org/wiki/Fish#Caveats for details"
52         elog
53         elog "To set your colors, run 'fish_config'"
54         elog "To scan your man pages for completions, run 'fish_update_completions'"
55         elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
56         elog
57         elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
58         elog "browser of your choice to get acces to ${PN}'s help system:"
59         elog "  BROWSER=\"/usr/bin/firefox\""
60         elog
61         elog "In order to get lzma and xz support for man-page completion please"
62         elog "emerge one of the following packages:"
63         elog "  dev-python/backports-lzma"
64         elog "  >=dev-lang/python-3.3"
65         elog
66         elog "If you have issues with cut'n'paste in X-terminals, install the"
67         elog "x11-misc/xsel package."
68         elog
69         elog "Have fun!"
70 }