app-shells/bashdb: bump to v5.0.1.1.2
[gentoo.git] / app-shells / bashdb / bashdb-5.0.1.1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_P="${PN}-${PV:0:3}-${PV:4}"
7 DESCRIPTION="bash source code debugging"
8 HOMEPAGE="http://bashdb.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2
10         test? ( https://dev.gentoo.org/~whissi/dist/bashdb/bashdb-4.4-1.0.0-missing-test-files.tar.xz )"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
19
20 S="${WORKDIR}/${MY_P}"
21
22 src_prepare() {
23         if use test ; then
24                 einfo "Copying missing files ..."
25                 # https://sourceforge.net/p/bashdb/bugs/52/
26                 cp -vafn "${WORKDIR}"/missing-files/* "${S}"/test || die
27         fi
28
29         default
30
31         # We don't install this, so don't bother building it. #468044
32         sed -i 's:texi2html:true:' doc/Makefile.in || die
33 }
34
35 src_configure() {
36         # This path matches the bash sources.  If we ever change bash,
37         # we'll probably have to change this to match.  #591994
38         econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
39 }