app-portage/portage-utils: sparc stable wrt bug #722778
[gentoo.git] / app-portage / tatt / tatt-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1 git-r3
9
10 DESCRIPTION="arch testing tool"
11 HOMEPAGE="https://github.com/gentoo/tatt"
12 EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/tatt.git
13         https://github.com/gentoo/tatt.git"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="+templates"
19
20 RDEPEND="
21         app-portage/eix
22         app-portage/gentoolkit[${PYTHON_USEDEP}]
23         dev-python/configobj[${PYTHON_USEDEP}]
24         dev-python/requests[${PYTHON_USEDEP}]
25         www-client/pybugz
26 "
27 BDEPEND="
28         dev-python/setuptools[${PYTHON_USEDEP}]
29 "
30
31 python_install_all() {
32         distutils-r1_python_install_all
33         if use templates; then
34                 insinto "/usr/share/${PN}"
35                 doins -r templates
36         fi
37         doman tatt.1
38         doman tatt.5
39 }