73af7bef033bf21399067df653fd674aecfe479f
[gentoo.git] / app-portage / tatt / tatt-0.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="arch testing tool"
11 HOMEPAGE="https://github.com/gentoo/tatt"
12 SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
17 IUSE="+templates"
18
19 RDEPEND="
20         app-portage/eix
21         app-portage/gentoolkit
22         dev-python/configobj[${PYTHON_USEDEP}]
23         dev-python/requests[${PYTHON_USEDEP}]
24         www-client/pybugz
25 "
26 DEPEND="${RDEPEND}
27         dev-python/setuptools[${PYTHON_USEDEP}]
28 "
29
30 python_install_all() {
31         distutils-r1_python_install_all
32         if use templates; then
33                 insinto "/usr/share/${PN}"
34                 doins -r templates
35         fi
36         doman tatt.1
37         doman tatt.5
38 }