proj/gentoo: Initial commit
[gentoo.git] / app-portage / pqlop / pqlop-0.02-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
8
9 inherit python-r1
10
11 DESCRIPTION="emerge.log parser written in python"
12 HOMEPAGE="https://bitbucket.org/LK4D4/pqlop"
13 SRC_URI="https://bitbucket.org/LK4D4/pqlop/raw/${PV}/pqlop.py -> ${P}.py"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="
21         ${PYTHON_DEPS}
22 "
23
24 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
25
26 S="${WORKDIR}"
27
28 src_unpack() {
29         :
30 }
31
32 src_install() {
33         newbin "${DISTDIR}"/${P}.py ${PN} || die "newbin failed"
34         python_replicate_script "${ED}"/usr/bin/${PN} || die "python_replicate_script failed"
35 }