app-portage/portage-utils: sh stable wrt bug #675960
[gentoo.git] / app-portage / portage-utils / portage-utils-0.74.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Small and fast Portage helper tools written in C"
9 HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
10 SRC_URI="mirror://gentoo/${P}.tar.xz
11         https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="nls static"
17
18 RDEPEND="dev-libs/iniparser:0"
19 DEPEND="${RDEPEND}
20         app-arch/xz-utils
21         static? ( dev-libs/iniparser:0[static-libs] )"
22
23 src_configure() {
24         # Avoid slow configure+gnulib+make if on an up-to-date Linux system
25         if use prefix || ! use kernel_linux || \
26            has_version '<sys-libs/glibc-2.10'
27         then
28                 econf --with-eprefix="${EPREFIX}"
29         else
30                 tc-export CC
31         fi
32 }
33
34 src_compile() {
35         emake NLS=$(usex nls) STATIC=$(usex static)
36 }