Use https by default
[gentoo.git] / app-portage / pms-test-suite / pms-test-suite-9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 PYTHON_DEPEND='2:2.6'
8 # Python ABIs are not supported by pkgcore
9 #SUPPORT_PYTHON_ABIS=1
10 # Python3 is not supported by dbus & gobject
11 RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
12 DISTUTILS_SRC_TEST=setup.py
13
14 inherit base distutils
15
16 #if LIVE
17 EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git
18         http://anongit.gentoo.org/git/proj/${PN}.git
19         https://bitbucket.org/mgorny/${PN}.git"
20 inherit git-2
21 #endif
22
23 DESCRIPTION="A test suite for Package Manager PMS compliance"
24 HOMEPAGE="https://www.gentoo.org/proj/en/qa/pms/pms-test-suite.xml"
25 SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
26
27 LICENSE="BSD-2"
28 SLOT="0"
29 KEYWORDS="~amd64 ~x86"
30 IUSE="doc test"
31
32 RDEPEND=">=app-portage/gentoopm-0.1.5
33         dev-python/dbus-python
34         dev-python/pygobject:2"
35 DEPEND="doc? ( dev-python/epydoc )
36         test? ( >=sys-apps/portage-2.1.10.3
37                 sys-apps/pkgcore
38                 >=sys-apps/paludis-0.64.2[python] )"
39
40 PYTHON_MODNAME=pmstestsuite
41
42 #if LIVE
43 KEYWORDS=
44 SRC_URI=
45 #endif
46
47 pkg_setup() {
48         python_set_active_version 2
49         python_pkg_setup
50 }
51
52 src_prepare() {
53         base_src_prepare
54         distutils_src_prepare
55 }
56
57 src_compile() {
58         distutils_src_compile
59
60         if use doc; then
61                 "$(PYTHON)" setup.py "${_DISTUTILS_GLOBAL_OPTIONS[@]}" doc || die
62         fi
63 }
64
65 src_install() {
66         distutils_src_install
67
68         if use doc; then
69                 dohtml -r doc/*
70         fi
71 }