app-portage/eix: alpha stable wrt bug #682792
[gentoo.git] / app-portage / gverify / gverify-1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
7 inherit python-single-r1
8
9 DESCRIPTION="gentoo.git signature verification tool"
10 HOMEPAGE="https://github.com/mgorny/gverify"
11 SRC_URI="https://github.com/mgorny/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="${PYTHON_DEPS}
19         app-crypt/gnupg
20         dev-vcs/git"
21 DEPEND="${PYTHON_DEPS}"
22
23 src_compile() {
24         emake PREFIX="${EPREFIX}"/usr
25 }
26
27 src_install() {
28         emake install DESTDIR="${D}" PREFIX=/usr
29         dodoc README
30 }