x11-base/xcb-proto: Drop support for Python 2.7.
[gentoo.git] / app-portage / golop / golop-0.0.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 EGO_PN=github.com/klausman/golop
6
7 if [[ ${PV} = *9999* ]]; then
8         inherit golang-vcs
9 else
10         KEYWORDS="~amd64 ~x86"
11         EGIT_COMMIT=v${PV}
12         SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
13         inherit golang-vcs-snapshot
14 fi
15 inherit golang-build
16
17 DESCRIPTION="A pure Go re-implementation of genlop"
18 HOMEPAGE="https://github.com/klausman/golop"
19 LICENSE="Apache-2.0"
20 SLOT="0"
21 IUSE=""
22 DEPEND=""
23 RDEPEND=""
24
25 src_install() {
26         dobin ${PN}
27
28         declare -a DOCS
29         DOCS+=( src/${EGO_PN}/README.md )
30         einstalldocs
31 }