app-portage/gemato: Port to py39
[gentoo.git] / app-portage / gemato / gemato-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python3_{6..9} pypy3 )
8 PYTHON_REQ_USE='threads(+)'
9
10 inherit distutils-r1 git-r3
11
12 DESCRIPTION="Stand-alone Manifest generation & verification tool"
13 HOMEPAGE="https://github.com/mgorny/gemato"
14 SRC_URI=""
15 EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
16
17 LICENSE="BSD-2"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="+gpg tools"
21
22 RDEPEND="
23         gpg? ( app-crypt/gnupg )"
24
25 distutils_enable_tests setup.py
26
27 python_install_all() {
28         distutils-r1_python_install_all
29
30         if use tools; then
31                 exeinto /usr/share/gemato
32                 doexe utils/*.{bash,py}
33         fi
34 }