dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / app-portage / g-sorcery / g-sorcery-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=(python3_6)
7
8 inherit distutils-r1 git-r3
9
10 DESCRIPTION="framework for ebuild generators"
11 HOMEPAGE="https://github.com/jauhien/g-sorcery"
12 SRC_URI=""
13 EGIT_BRANCH="master"
14 EGIT_REPO_URI="git://git.gentoo.org/proj/g-sorcery.git"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 IUSE="bson git"
19
20 DEPEND="bson? ( dev-python/pymongo[${PYTHON_USEDEP}] )
21         git? ( dev-vcs/git )
22         sys-apps/portage[${PYTHON_USEDEP}]"
23 RDEPEND="${DEPEND}"
24 PDEPEND=">=app-portage/layman-2.2.0[g-sorcery(-),${PYTHON_USEDEP}]"
25
26 python_test() {
27         PYTHONPATH="." "${PYTHON}" scripts/run_tests.py || die
28 }
29
30 python_install_all() {
31         distutils-r1_python_install_all
32
33         doman docs/*.8
34         docinto html
35         dodoc docs/developer_instructions.html
36         diropts -m0777
37         dodir /var/lib/${PN}
38         keepdir /var/lib/${PN}
39 }